HobbyPCB.com

Built by Hobbyist for Hobbyist!
It is currently Thu Oct 02, 2014 1:41 am

All times are UTC - 5 hours




Post new topic  [ 195 topics ]  Go to page Previous  1, 2, 3, 4, 5, 6, 7, 8  Next
 Topics   Author   Replies   Views   Last post 
No unread posts KX3 HR50 Auto Bandswitching Mod success

WA8EBM

6

1070

Mon Dec 23, 2013 7:59 pm

johnnysiu View the latest post

No unread posts version 1.5A software

jaksha

3

389

Wed Dec 18, 2013 8:22 am

johnnysiu View the latest post

No unread posts Hardrock50

hb9dds

1

339

Tue Dec 17, 2013 10:19 pm

cpope View the latest post

No unread posts QSK board up and running

millerhill

1

346

Sat Dec 14, 2013 11:34 am

jimveatch View the latest post

No unread posts Unable to get the Elecraft KX receive mode enabled message

johnnysiu

1

336

Sun Dec 08, 2013 2:11 am

johnnysiu View the latest post

No unread posts S/N 1169 on the air - fw issue tho

justpete

1

335

Tue Dec 03, 2013 10:14 pm

jimveatch View the latest post

No unread posts Lower output on 20M and 17M

KJ6PTX

3

545

Tue Nov 05, 2013 12:07 pm

KJ6PTX View the latest post

No unread posts PA Board T1 Fitment

raiders

3

602

Tue Oct 29, 2013 9:51 am

johnnysiu View the latest post

No unread posts Amp Mysteriously Powers Off

wongtheo

2

513

Tue Oct 29, 2013 9:46 am

johnnysiu View the latest post

No unread posts KX3 to 50 question

millerhill

9

1280

Tue Oct 08, 2013 8:07 pm

jimveatch View the latest post

No unread posts Problem with VR4 Adjustment

raiders

8

735

Tue Oct 08, 2013 1:25 am

raiders View the latest post

No unread posts Operation instructions

millerhill

1

451

Mon Oct 07, 2013 3:52 pm

jimveatch View the latest post

No unread posts band switching for HR50

johnnysiu

2

609

Fri Oct 04, 2013 3:06 am

johnnysiu View the latest post

No unread posts how hot is too hot.

N6SDR

2

531

Wed Sep 25, 2013 9:25 pm

N6SDR View the latest post

No unread posts trouble setting bias.

pgenera

4

642

Wed Sep 25, 2013 3:30 pm

pgenera View the latest post

No unread posts It's Alive S/N 1141

wongtheo

1

410

Mon Sep 23, 2013 7:10 am

jimveatch View the latest post

No unread posts Amp not working after calibration

N6SDR

2

518

Thu Sep 19, 2013 10:51 pm

N6SDR View the latest post

No unread posts MARS operation

N6SDR

2

472

Thu Sep 19, 2013 8:39 pm

N6SDR View the latest post

No unread posts Ribbon cable orientation question

millerhill

1

753

Wed Sep 18, 2013 8:40 pm

jimveatch View the latest post

No unread posts Missing Part

wongtheo

1

426

Sat Sep 14, 2013 10:25 am

jimveatch View the latest post

No unread posts missing parts

Parkhc1

1

480

Sat Sep 07, 2013 6:42 pm

cpope View the latest post

No unread posts S/N 1019 low output 10M

wabrand

5

863

Thu Aug 29, 2013 6:31 am

jimveatch View the latest post

No unread posts Backlight only blue screen

kb2ngk

2

558

Tue Aug 27, 2013 6:33 am

jimveatch View the latest post

No unread posts Missing Capacitors on my Rev E Board?

myflyertrains

0

664

Sat Aug 24, 2013 4:14 am

myflyertrains View the latest post

No unread posts Attachment(s) S/N 1012 burnt components while tuning up on 12 mters...

n8klx

4

671

Thu Aug 22, 2013 12:01 pm

n8klx View the latest post

Display topics from previous:  Sort by  
Post new topic  [ 195 topics ]  Go to page Previous  1, 2, 3, 4, 5, 6, 7, 8  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


Unread posts Unread posts    No unread posts No unread posts    Announce Announcement
Unread posts [ Popular ] Unread posts [ Popular ]    No unread posts [ Popular ] No unread posts [ Popular ]    Sticky Sticky
Unread posts [ Locked ] Unread posts [ Locked ]    No unread posts [ Locked ] No unread posts [ Locked ]    Moved topic Moved topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group