HobbyPCB.com
https://www.hobbypcb.com/phpBB3/

ATU testing
https://www.hobbypcb.com/phpBB3/viewtopic.php?f=8&t=7322
Page 1 of 1

Author:  bryan@bbbrauer.com [ Thu Apr 12, 2018 12:29 pm ]
Post subject:  ATU testing

Is there a way to test the ATU? I am recently experiencing problems tuning to the upper end of the 40 meter band. I cannot get better than about 4.0:1. If I by pass the HR50, I can tune to 1:1 with my KX2, so I know it is not the antenna. Plus, if I drop down slightly in the band, the HR50 tuner will tune to 1.2:1. Could I have a "sticky" relay?

Thanks,

AI6B (formerly KB6BB)

Author:  jimveatch [ Fri Apr 13, 2018 5:13 am ]
Post subject:  Re: ATU testing

Hi,

Yes there is a set of commands designed to allow you to exercise individual steps in the L's and C's in the ATU. If you connect the HR50 to a PC using USB, you can use a terminal emulator program, like Termite, to set the L's and C's in the tuner. There are a total of 7 inductors and 7 capacitors for 127 steps. To test L's set C to 0 and set L to 0,1,2,4,8,16,32,64 in sequence this will test each individual coil. Set L to 0 to test the caps.

The operating manual has the command format on page 21, which I'll copy here:

HRTM; (HR50 ATU Message/Response)

SET/RSP format HRTM<tuner message>;

Example HRTMC?; requests the current capacitor setting in the ATU.
HR50 responds HRTM 8; the ATU capacitor is set to step 8 out of 127

Tuner Messages:

A Initiate an autotune sequence
Bxx, B? Set/query band setting uses bands listed above except UNK = 11
Cxxx, C? Set/query capacitor step value (0 - 127)
E Commands tuner to erase all stored tuning solutions
Fxxx, F? Set/query ATU memory channel
Hx, H? Set/query capacitor position 0 = input, 1 = output
I Query ATU information responds ‘HRTMHR50 ATU version x.x’
Lxxx, L? Set/query inductor step value (0 – 127)
Px Query RF power reading x = F (average fwd), R (average reverse), P (PEP forward)
Q Store the currently applies tuning solution in the current freq/band memory
S Query the status of the last autotune cycle S (success), F (fail), L (power too low), A (abort)
V Query the ATU firmware revision responds ‘HRTMx.x;’
W Query SWR reading responds 1.0 – 9.9 or --- if the power is too low
Yx, Y? Set/query ATU bypass 0 = engaged, 1 = bypassed

Please let us know what you find.

73,
Jim WA2EUJ

Author:  bryan@bbbrauer.com [ Sat Apr 14, 2018 9:52 pm ]
Post subject:  Re: ATU testing

Thanks Jim,

I am unable to get a handshake with Termite 3.4. Using Baud Rate 38400, 8N1. Com Port verified.

AI6B

Author:  jimveatch [ Sun Apr 15, 2018 1:40 pm ]
Post subject:  Re: ATU testing

I'm not sure what you mean by 'unable to get a handshake'.

Do you have the USB Baud rate in the HR50 set to 38400? Not the ACC Baud rate that's a different port.

Set Termite to terminate the line with a <CR> then send "HRBN;<CR>" without the quotes. The HR50 should respond with the number of the band that it's set to.

Jim.

Author:  bryan@bbbrauer.com [ Mon Apr 16, 2018 10:09 pm ]
Post subject:  Re: ATU testing

I cannot get Termite to communicate with my HR50. What mode should my HR50 be in? I have it "on" Key:Off. Menu 3, Termite and Comm Port all set to 38500, 8,1,N.

Thanks,

AI6B
Bryan

Author:  jimveatch [ Tue Apr 17, 2018 5:35 am ]
Post subject:  Re: ATU testing

Hi Bryan,

Are you certain that you know which COM port is the HR50?

Turn on the HR50 and unplug the HR50's USB cable, go to Divice Manager, expand the 'Port (COM & LPT) tab, the plug in the HR50's USB cable and see which port shows up in the list.

The HR50 communicates in every mode except during a transmission. You can issue commands the change the HR50's mode.

Can you send me screen shots of your termite set up?

jim (at) hobbyPCB (dot) com

73,
Jim WA2EUJ

Author:  bryan@bbbrauer.com [ Tue Apr 17, 2018 11:31 am ]
Post subject:  Re: ATU testing

Jim,

Thanks for sticking with this. I am quite sure that I have everything set up correctly. I checked the Com port at the start when I installed Termite. It might be my USB cable. I will be at my home QTH on Thursday where I have other cables and will try again. Stay tuned.

73,
AI6B

Author:  bryan@bbbrauer.com [ Wed Apr 18, 2018 11:38 pm ]
Post subject:  Re: ATU testing

Jim,

I tried it at my home, with a different cable and with Termite on a different PC: same result.

Attached is screen shot of setup. I am probably missing something basic here.

Maybe I have a bad connection on the HR50 rear panel. I just received the rear panel upgrade kit today in the mail. Maybe I should install it before I try again.

I tried to upload a screenshot.png, but received an error message that maximum allowed file size is 2MB. I scaled the file down to 1.88 MB and tried again to load it, and received the error message that the maximum allowed size is 256 K. I tried various options of tiff and jpg, all less than 2M, and was not able to upload a file.

Needless to say, I feel like a damn idiot, and am about to give up. I will try emailing you the screenshot png.

AI6B

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/